Weekend Sale! Get EVERYTHING at Joomlashack for as low as $97 per year!  Sale ends in 1 Day
Joomlashack

Joomlashack PHP and Joomla Version Requirements

PHP Version Requirements

We highly recommend that any website using Joomashack also uses at least PHP 5.6.

Why PHP 5.6? Because PHP itself does not support anything lower than 5.6. Click here for more details on PHP version support. Any version of PHP before 5.6 doesn’t have security updates and will not keep your site safe.

The official Joomla recommendation is PHP 5.6 or higher. Click here to see Joomla's recommendations.

Joomla Version Requirements

We only support the latest version of Joomla 3. If you're unsure about the latest version of Joomla, click here to visit Joomla.org. At the time of writing, the latest version of Joomla is 3.7.5:

joomla latest version

What Version of PHP and Joomla Do I Have?

If you don't know what version of PHP or Joomla your site is using, here's how to find out:

  • In your Joomla site, go to System > System Information:

system info

  • Both your Joomla and PHP versions will be visible on this page:

joomla php versions

What Should I Do if My PHP Version is Below 5.6?

Copy-and-paste this text and send it to your hosting company:

I'm interested in running the Joomla web software and I was wondering if my account supported the following:

  • PHP 5.6 or greater
  • MySQL 5.5 or greater OR MariaDB 10.0 or greater
  • The mod_rewrite Apache module
  • HTTPS support

Thanks!

 

 

Since 2005, Joomlashack has been a leading supplier of free and commercial Joomla templates, Joomla extensions, and Joomla Training.
Joomlashack.com is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.