Joomlashack Will Require PHP 7 When Joomla 4 Arrives

Joomlashack Will Require PHP 7 When Joomla 4 Arrives

Over the last couple of years, the Joomla community has been moving to PHP 7 as a minimum requirement.

Leading extension developers such as Peter from Regular Labs and Nicholas from Akeeba have already dropped PHP 5.6 support on their extensions. Joomla itself is prompting users to update to at least PHP 7.3, with messages like this:

PHP Version warning

Here at Joomlashack, we've waited to make that move, but the time is fast approaching. When Joomla 4.0 is released, it will not run on PHP 5. And so it seems like the best time to update our requirements too.

All Joomlashack extensions will require PHP 7 when Joomla 4.0 arrives. This applies to both the Joomla 3 and the Joomla 4 versions of our extensions.

This is a very helpful guide that explains just how out-of-date PHP 5 is. Active support ended 4.5 years ago and security support ended 2 years and 5 months ago.

Your site will be faster and more secure on PHP 7 or 8. If you need any help to update your site, you're always welcome to contact Joomlashack's support team.

About the author

Steve is the CEO of Joomlashack. Originally from the UK, he now lives in Sarasota in the USA. Steve has been involved with Joomla since 2006.