Technical Requirements for OSTimer

For normal operation of OSTimer on your site, please make sure your site meets the following technical requirements.

PHP Requirements

We strongly suggest using at least PHP 5.6. PHP itself doesn't support any versions lower than 7.2. Click here to see more details on currently supported PHP versions or see the "Supported Versions" diagram below.

Currently supported PHP versions

Any version of PHP before 7.2 doesn’t have security updates and will not keep your site safe.

As you can see from the diagram, any release of PHP lower than 7.2 is marked as "End of life". According to the PHP website, a PHP release marked as "End of life" is:

A release that is no longer supported. Users of this release should upgrade as soon as possible, as they may be exposed to unpatched security vulnerabilities.

The official Joomla recommendation is PHP 7.2 or higher. Click here to see Joomla's recommendations.

Database Requirement

  • MySQL: version 5.5.3 or newer.

Web Server Requirement

  • Apache: version 2.4 and newer.
  • Nginx: version 1.8 and newer.
  • Microsoft IIS: version 7 and newer.

Joomla Version Requirements

Joomlashack supports the latest version of Joomla 3.9. If you're unsure about the latest version of Joomla, click here to visit

What Version of PHP, Database, and Joomla Do I Have?

If you are not sure what version of PHP or Joomla your site is currently running, here's how you can find it out:

In your Joomla site, go to System > System Information:

System Information

Both your Joomla and PHP versions will be visible on this page:

Joomla PHP supported versions

What Should I Do if My PHP Version is Below 5.6?

Copy-and-paste this text and send it to your hosting company:

I'm interested in running the Joomla web software and I was wondering if my account supports the following:
  • PHP 5.6 or greater
  • MySQL 5.5 or greater
  • The mod_rewrite Apache module
  • HTTPS support